Postgre SQL


#1

bonjour,

J’ai installé hier PT4 et je l’ai testé une bonne partie de la journée, tout fonctionnait très bien.

Ce matin j’allume mon PC (W10) qui me signale un dysfonctionnement. La réparation se fait toute seule. Je pensais que tout allait bien et au moment de lancer PT4 …patatrat ça ne fonctionne plus. Aprés quelques minutes une pop up PT4 apparait avec ce message :

“Unable to login to database (postgres). Reason: could not connect to server: Connection refused (0x0000274D/10061) Is the server running on host “???” and accepting TCP/IP connections on port 5432?Unable to login to database (postgres). Reason: could not connect to server: Connection refused (0x0000274D/10061) Is the server running on host “???” and accepting TCP/IP connections on port 5432?”

J’ai essayé de désactiver le pare feu, de créer une autre base de données, rien n’y fait …
Si quelqu’un pouvait m’aider …

:unamused:


#2

Hello @artur13000 ,

Il te faut tout d’avoir vérifier que ton serveur Postgre est bien démarré.
Pour cela tapes dans la barre de démarrage : services.msc ce qui va t’ouvrir la fenêtre des services windows. Ensuite tu cherche le service Postgree et tu vérifie s’il est bien démarré. S’il ne l’est pas : bouton droit et start.

Ensuite si c’est bien démarré : tu peux lancer PgAdmin III pour voir si tu arrives bien à t’y connecter.


#3

Merci pour ton aide Exonico
Malheureusement j’ai un message d’erreur

sql Screenshot - 27_09_2017 , 18_43_51

Je ne peux donc pas passer à l’étape 2 …


#4

Je dois décoller la mais je rejetterai un oeil chez moi.
Au pire une install d’une version 9.3 par dessus devrait résoudre le pb… bien qu’a mon avis il faudra faire un peu de ménage avant…


#5

Regardes dans le répertoire data de postgre si tu as un fichier postmaster.pid genre \postgresql\8.4\data\postmaster.pid

Si oui supprimes le et redémarres le service.


#6

Nan, il y a juste un “postmaster.opts” et celui là je crois qu’il faut pas le toucher …


Et d’après ce tuto, la mise à jour s’installe à côté et pas par dessus …???
http://www.inspyration.org/tutoriels/mettre-a-jour-postgresql-8.4-vers-9.1


#7

Bon pas de bol …
Du coup va falloir se palucher les logs. Regardes dans le répertoire pg_log les derniers fichiers de logs et vous si il y a plus d’indicatIons


#8

Je ne sais pas si je cherche au bon endroit ???
le seul fichier dans pg_log que j’ai c’est un fichier de novembre 2016 …!!!

répertoire : C:\postgreSQL\data\pg_log

A mon avis quand w10 a réparé ce matin il a fait beaucoup de dégats …


#9

Je dois dire que je suis étonné que PT4 utilise une version aussi vieille que la 8.3
Es tu sur de pas en avoir d’autre ? Regardes dans tous les Program Files etc …


#10

Quand j’ai installé hier je pensais qu’il allait me dire "vous devez installer la base de données’… et puis non il a repris l’ancienne version que j’avais installé fin 2016 quand j’ai testé HM2…
du coup l’installation s’est poursuivie comme ça et ça a bien fonctionné toute la journée…

Je suis également curieux de savoir pourquoi ce plantage ? si c’est fréquent je préfère rester sur Xeester…
Surtout que la BD c’est pas trop ma tasse de thé … :slight_smile:


#11

Honnêtement si tu as installé PT4 qu’hier c’edt Pas grave si tu paumes ta base et donc t’as pas besoin d’upgrader postgre.
Ce que je ferais à ta place, j’irai dans les services et désactiverais le service 8.4 puis t’installes une version 9.3 en changeant le port pour 5433 par ex.
Puis dans PT 4 tu changes le port et tu recrée une nouvelle base.


#12

de toutes façons je pense que j’ai perdu tous les historiques de mains que j’avais transféré donc pourquoi ne pas tout réinstaller ?


#13

yep c’est le point. mais pkoi tu as tout perdu ? a cause du crash ?


#14

Postgresql 8.4 et win10 ne font pas bon ménage.
Faut intaller la 9.2.2 j enverrai le lien dans un prochain post.
faut desintaller 8.4 car plusieurs postgresql de versions différentes peuvent démarrer et être en process actif en même temps. Cela bouffe beaucoup de ressources au pire tu empêches le démarrage du service.
Bon courage car postgres est un programme capricieux.

++
++


#15

passe par ici pour télécharger postgres 9.2.2, avec installation auto, faut décocher stackbuilder à la fin.
https://www.enterprisedb.com/downloads/postgres-postgresql-downloads#windows

plus dur les archives de postgresql :
https://www.openscg.com/bigsql/postgresql/archive-packages/

++


#16

@Exonico A vrai dire je ne sais pas pourquoi ce crash … J’avais tout quitté normalement cette nuit …

Merci à vous 2 @Exonico et @PetScotNiel
Je vais virer cette version obsolète et donner une dernière chance à PT4 …


#17

Oups c’est quoi ces archives ??? J’en fais quoi ?


#18

passe par le premier lien, je te donnais juste une autre possibilité.
++


#19

merci
En fait, j’ai compris après coup
Et pourquoi on met la version 9.2 et pas la dernière plus récente ?


#20

c’est comme tu veux mais pas la 9.5 et au delà.
++